[smartmontools-support] Drive PASSED health check but will not take partition table

David Niklas doark at mail.com
Tue Aug 22 17:23:25 CEST 2017

On Wed, 16 Aug 2017 17:40:07 +0200
Dan Lukes <dan at obluda.cz> wrote:
> doark at mail.com wrote:
> > I ran a full test of the drive which completed with a read error, yet
> > the drive passed the health check and was more healthy than the also
> > refurbished Seagate model. I rewrote the partition table and resyned
> > the array and rebooted to find that the partition table was again
> > lost. I tried this a third time with the same result.
> > 
> > So, what I want to know is:
> > 1: What killed this drive?  
> Well, simple question may not have simple answer. Moreover, some 
> informations are missing - for example what you mean "partition table 
> was lost" (damaged content ? empty at all ? unreadable ?).

The partition table was unreadable. The drive showed up in gparted as a
blank (virgin) hard drive.

> According data you disclosed, WD identified Uncorrectable read error of 
> physical sector starting on LBA 103890953. It seems not to be partition 
> table sector, thus all I can tell is - no records related to partition 
> table issue, no data for analysis.

That is why I'm confused.
I thought my problem might have something to do with the
Raw_Read_Error_Rate of 0x000000000097.

> > 2: Why is the health check passing?  
> While SMART protocol itself is standardized, the meaning of values 
> reported are vendor specific. Different vendors, different models and 
> even different firmware versions have no common standard what disc 
> health is or how to test it.
> Se answer to your question is - according tests the Western Digital 
> considered appropriate - your disk is not failing.

OK, so the drive does not give a pass or fail value to it's health,
rather that is deduced from the smart data that smartmontools is able to

> > 3:And most importantly, do I need to do anything about the Seagate
> > drive whose health is worse (I continue to use it)?  
> I see nothing wrong with data reported by Seagate. Low Power On Hours, 
> zero Rellocated Sectors/Event Count as well as Current Pending Sector.

I was concerned about the Seek_Error_Rate and the Raw_Read_Error_Rate.
They are currently 120408357 and 90758872. I've tried looking for
information on what exactly they indicate without much success.
I'm enclosing the latest smart data.

> Im not taking responsibility over your data, but in my hubmle opinion. 
> both Hitachi and Seagate looks good.
> Dan

I would not ask that of you, I'm looking for advice.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: sdb-17.txt.bz2
Type: application/x-bzip
Size: 2226 bytes
Desc: not available
URL: <https://listi.jpberlin.de/pipermail/smartmontools-support/attachments/20170822/42a3e520/attachment.bz2>

More information about the Smartmontools-support mailing list