[smartmontools-support] Drive PASSED health check but will not take partition table

Dan Lukes dan at obluda.cz
Wed Aug 16 17:40:07 CEST 2017

doark at mail.com wrote:
> I ran a full test of the drive which completed with a read error, yet the
> drive passed the health check and was more healthy than the also
> refurbished Seagate model. I rewrote the partition table and resyned the
> array and rebooted to find that the partition table was again lost. I
> tried this a third time with the same result.
> So, what I want to know is:
> 1: What killed this drive?

Well, simple question may not have simple answer. Moreover, some 
informations are missing - for example what you mean "partition table 
was lost" (damaged content ? empty at all ? unreadable ?).

According data you disclosed, WD identified Uncorrectable read error of 
physical sector starting on LBA 103890953. It seems not to be partition 
table sector, thus all I can tell is - no records related to partition 
table issue, no data for analysis.

> 2: Why is the health check passing?

While SMART protocol itself is standardized, the meaning of values 
reported are vendor specific. Different vendors, different models and 
even different firmware versions have no common standard what disc 
health is or how to test it.

Se answer to your question is - according tests the Western Digital 
considered appropriate - your disk is not failing.

> 3:And most importantly, do I need to do anything about the Seagate drive
> whose health is worse (I continue to use it)?

I see nothing wrong with data reported by Seagate. Low Power On Hours, 
zero Rellocated Sectors/Event Count as well as Current Pending Sector.

Im not taking responsibility over your data, but in my hubmle opinion. 
both Hitachi and Seagate looks good.


More information about the Smartmontools-support mailing list