[smartmontools-support] smartctl fails but badblocks succeeds

Carlos E. R. robin.listas at telefonica.net
Mon Jun 27 18:24:50 CEST 2022

On 2022-06-27 17:17, Alex wrote:
> Hi,
> On Sun, Jun 26, 2022 at 2:33 AM Carlos E. R. <> wrote:
>     On 2022-06-12 23:29, Alex wrote:
>     > Hi,
>     > I have an older WD1502FAEX 1.5TB disk that fails a smartctl short and
>     > long test at virtually the same place on the disk with a read error.
>     > However, running badblocks over the same place on the disk where
>     > smartctl fails has no problem, even after multiple read/write passes.
>     >
>     > Which test do I believe? Is this a reliable disk?
>     >
>     > If they're just read errors, isn't there some mechanism to relocate
>     > those bad sectors or just mark them as unusable and move on?
>     Writing to that sector causes the disk firmware to relocate it, if it is
>     bad when writing.
>     When in doubt, I backup the entire disk, then write it full of zeroes
>     with dd. Then I run the smart long test, and decide.
> Thanks for your help. I've already tried to run badblocks around the
> specific areas that failed, and smartctl still fails after that.

AFAIK, badblocks doesn't write. You have to write.

> I'll try to do it on the whole disk, but it would take many hours.


Certainly, but it will catch any other error.

Cheers / Saludos,

		Carlos E. R.

  (from Elesar, using openSUSE Leap 15.3)

More information about the Smartmontools-support mailing list