[smartmontools-support] Smartctl error prevents me from retrieving SMART data for a drive

asorewinner asorewinner at protonmail.com
Tue Nov 20 07:38:35 CET 2018

Hi everyone,

I recently got an error when trying to use GSmartControl to read SMART data on one of my external hard drives.

The drive shows up as an Unknown model, even though GSmartControl had previously worked on it. When I right-click and go to View Details, it shows "Cannot retrieve SMART data - Device open failed, or device did not return an IDENTIFY DEVICE structure."

Running "sudo smartctl -x /dev/sdx" where sdx was the drive in question, I got "Read Device Identity failed: scsi error unsupported field in scsi command. A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options."

I appear to be able to read data from the drive just fine, and I haven't dropped or jostled it recently. The drive has also worked with GSmartControl many times previously, though I may have had to set the -d sat parameter.

I also tested the drive on Windows. The Windows version of GSmartControl was able to read the drive without any problems, and the drive itself is in good health.

What could be wrong? Any help would be appreciated!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://listi.jpberlin.de/pipermail/smartmontools-support/attachments/20181120/c0323dee/attachment.html>

More information about the Smartmontools-support mailing list