[qutebrowser] entering in text fields

Florian Bruhin me at the-compiler.org
Thu Nov 23 21:28:57 CET 2017


On Thu, Nov 23, 2017 at 07:59:22PM +0000, Stephen Davies (sdavies) wrote:
>     1) Pet peeve: when the focus is in a text field, I get a blinky vertical
> cursor even if I'm not in insert mode. That seems really strange since afaik
> "blinky vertical cursor" pretty much universally means "if you type right now,
> your keystrokes will go into this field." I'd like it if I only got blinky
> cursor when I'm actually in insert mode, rather than having to simultaneously
> visually track the status bar. Would others want this behavior? (I guess if it
> worked the way I'm describing, though, there would have to be another,
> different-looking cursor when the field is in focus but you're not in insert
> mode, because otherwise you couldn't navigate within the field; see #2 below.)

So far nobody found a way to hide the cursor (which is drawn by
QtWebKit/QtWebEngine) without introducing other side effects. See

>     2) When I'm in a text field but *not* in insert mode, I'd like to be able
> to do vim-like cursor commands to move around in that field. hjkl work exactly
> like I expect in this mode, but others ("0" to jump to start of line or "$" to
> jump to end, for instance) do not. I tried the following config binding:
> config.bind('0', 'move-to-start-of-line', mode='insert')
>     but when I tried it, I got the message "move-to-start-of-line: This
> command is only allowed in caret mode, not normal." Other messages make me
> think caret mode isn't currently implemented. Am I stuck then?

There are various related things here:

- Having readline-like bindings in insert mode:

- Having a vim-like editor in insert mode:

- Having a working caret mode (which is for selecting text on the page, not for
  form elements) with QtWebEngine:

>     3) Absolutely *love* the open-editor command to drop me into an external
> vim window where I can edit and save and return to page with my text inserted.
> (That one feature might be killer enough to have made me switch to qutebrowser
> even if it had nothing else!)  One problem, though: when I exit my editor and
> return to the page as described, I want to be able to press "enter" to get it
> to take my input (say I typed in google search terms in my editor, and now
> want Google to do my search.) But the "enter" key doesn't seem to work in this
> situation, and "escape" doesn't do anything either -- I have to go to the
> mouse and press the page's submit button (which eliminates most of the
> advantage of doing this operation at all). Is there a workaround anyone knows?

Works fine for me. Can you reproduce it when starting with --temp-basedir? Can
you show your ":open qute:version" output?


https://www.qutebrowser.org  | me at the-compiler.org (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072  | https://the-compiler.org/pubkey.asc
         I love long mails!  | https://email.is-not-s.ms/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://listi.jpberlin.de/pipermail/qutebrowser/attachments/20171123/426016d3/attachment.asc>

More information about the qutebrowser mailing list