Tags not responding to mouse clicks

Kinley Dorji kinleyd at gmail.com
Wed Jan 14 07:10:51 CET 2015

Resending to make sure original thread is linked to this update:

Solved! The keyboard was fine. The superkeys weren't responding because
someone (probably my younger daughter) had pulled the game lock key.
Switching backk solved that problem. But the dzen2 bar continued to be
unresponsive to clicks. So after living with using the superkey + tag index
to switch between tags till now, I decided to relook at the problem.

I took a closer look at hlwm's autostart and panel.sh scripts. I came
across this snippet in panel.sh which looked like something to hack:

  if [ ! -z "$dzen2_svn" ] ; then
     echo -n "^ca(1,herbstclient focus_monitor $monitor && "'herbstclient
use "'${i:1}'") '"${i:1} ^ca()"
    echo -n " ${i:1} "

Since I'm using dzen2-git, I thought I'd try changing the else section from:
  echo -n " ${i:1} "
  echo -n "^ca(1,herbstclient focus_monitor $monitor && "'herbstclient use
"'${i:1}'") '"${i:1} ^ca()"

And it worked.

I have no idea why the original panel.sh version worked before my Logitech
keyboard hacks and why it didn't work later as I didn't touch panel.sh nor
do I think the keyboard hacks would have. Still, happy to be back to status
quo. :)

On Thu, Sep 11, 2014 at 10:13 PM, Kinley Dorji <kinleyd at gmail.com> wrote:

> Hi all,
> Not sure what the problem is, but it started after I upgraded my system to
> the kernel v. a couple of days ago. Everything else works except
> my system doesn't respond to clicks on the tag names when I try to switch
> tags via the mouse. Win+[Tag Number] still works though, so it's not a
> complete show stopper.
> I'm on hlwm 0.6.2-2.
> Suggestions/help/fixes are in welcome!
> Thanks,
> Kinley
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://listi.jpberlin.de/pipermail/hlwm/attachments/20150114/561d544d/attachment.htm>

More information about the hlwm mailing list